logo
Thread Tools
Old 05-25-2019, 05:48 PM
dshriver is online now
Find More Posts by dshriver
Registered User
dshriver's Avatar
United States, TX, Cypress
Joined Oct 2014
978 Posts
Discussion
Smoke problems

Hello!

I'm having trouble with my smoke system and I'm hoping someone might have some suggestions on how to fix it.

When I turn the smoke on, in the air, I get puffs of smoke. The smoke comes and goes. It seems to run for less than a second, then off, then back on for another short run. Other times when I turn it on, I get no smoke at all.

The part that has me really confused is that it works great on the ground. The smoke runs just fine at all throttle settings and produces a great amount of smoke.

Here's the setup:
Hemple 1/4 scale clipped wing cub
DA-50
Slimline pitts muffler
Bad Dog smoke nozzle
Powerbox smoke pump on 2S Life
Viton tubing
PAU 12oz smoke tank
dshriver is online now Find More Posts by dshriver
Reply With Quote Quick reply to this message
Sign up now
to remove ads between posts
Old 05-25-2019, 06:50 PM
Supermod56 is offline
Find More Posts by Supermod56
Registered User
United States, ID, Nampa
Joined Jan 2006
428 Posts
You have a check valve in the line to the muffler?
Supermod56 is offline Find More Posts by Supermod56
Reply With Quote Quick reply to this message
Old 05-25-2019, 07:17 PM
dshriver is online now
Find More Posts by dshriver
Registered User
dshriver's Avatar
United States, TX, Cypress
Joined Oct 2014
978 Posts
I don’t. The last plane that used this pump had a check valve but I didn’t use one this time. I had read that due to the right gear mesh of the Powerbox pumps that it wasn’t required. However, adding a check valve is my next troubleshooting step.
dshriver is online now Find More Posts by dshriver
Reply With Quote Quick reply to this message
Old 05-25-2019, 09:13 PM
Supermod56 is offline
Find More Posts by Supermod56
Registered User
United States, ID, Nampa
Joined Jan 2006
428 Posts
I've never tried a Powerbox pump, all mine are Don Harris, next one will be though
Supermod56 is offline Find More Posts by Supermod56
Reply With Quote Quick reply to this message
Old 05-26-2019, 09:32 PM
crankcase is online now
Find More Posts by crankcase
www.baddogsmokes.com
crankcase's Avatar
United States, MN, Isanti
Joined Apr 2016
336 Posts
..
crankcase is online now Find More Posts by crankcase
Last edited by crankcase; 05-26-2019 at 09:36 PM. Reason: ..
Reply With Quote Quick reply to this message
Old 05-26-2019, 09:37 PM
dshriver is online now
Find More Posts by dshriver
Registered User
dshriver's Avatar
United States, TX, Cypress
Joined Oct 2014
978 Posts
Thanks crankcase. Do you think not having a check valve might be my issue? This setup is a single nozzle fed from a Powerbox pump.
dshriver is online now Find More Posts by dshriver
Reply With Quote Quick reply to this message
Old 05-26-2019, 09:41 PM
crankcase is online now
Find More Posts by crankcase
www.baddogsmokes.com
crankcase's Avatar
United States, MN, Isanti
Joined Apr 2016
336 Posts
Quote:
Originally Posted by dshriver View Post
Thanks crankcase. Do you think not having a check valve might be my issue? This setup is a single nozzle fed from a Powerbox pump.
I just caught that and deleted my response. Sorry about that. I have not seen this issue before on a single cylinder setup. It would be a simple check. The gear heads on a PB pump are really built well and tight. I'm scratching my head on this one.
crankcase is online now Find More Posts by crankcase
Reply With Quote Quick reply to this message
Old 05-26-2019, 09:45 PM
crankcase is online now
Find More Posts by crankcase
www.baddogsmokes.com
crankcase's Avatar
United States, MN, Isanti
Joined Apr 2016
336 Posts
How about your smoke tank vent line? Any chance that the line is not venting properly when your in the air causing a vapor lock situation?
crankcase is online now Find More Posts by crankcase
Reply With Quote Quick reply to this message
Old 05-26-2019, 09:45 PM
dshriver is online now
Find More Posts by dshriver
Registered User
dshriver's Avatar
United States, TX, Cypress
Joined Oct 2014
978 Posts
The pump does have a lot of time on it. Maybe it’s worn to the point that the mesh isnt so tight. I need to order a check valve.

I suppose it could be a vent line issue. The tank fills and drains fine but it could be pushing air through the pump/nozzle. I’ll try redoing the plumbing.
dshriver is online now Find More Posts by dshriver
Reply With Quote Quick reply to this message
Old 06-15-2019, 02:47 PM
crankcase is online now
Find More Posts by crankcase
www.baddogsmokes.com
crankcase's Avatar
United States, MN, Isanti
Joined Apr 2016
336 Posts
Quote:
Originally Posted by dshriver View Post
The pump does have a lot of time on it. Maybe itís worn to the point that the mesh isnt so tight. I need to order a check valve.

I suppose it could be a vent line issue. The tank fills and drains fine but it could be pushing air through the pump/nozzle. Iíll try redoing the plumbing.
Any luck with issue? I know we discussed a few more options via text message. Feel free to text me or post here if I can be of further assistance. I curious as to the root cause of this issue.
-H
crankcase is online now Find More Posts by crankcase
Reply With Quote Quick reply to this message
Old 06-15-2019, 03:15 PM
dshriver is online now
Find More Posts by dshriver
Registered User
dshriver's Avatar
United States, TX, Cypress
Joined Oct 2014
978 Posts
Hey Harlan. Thanks again for your help. I have the smoke nipple relocated and I’ve redone all the plumbing. But I’ve been out of town for work and haven’t had a chance to test it.
dshriver is online now Find More Posts by dshriver
Reply With Quote Quick reply to this message


Quick Reply
Message:


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools