logo
Thread Tools
Old 04-14-2020, 05:37 PM
pipercub66 is offline
Find More Posts by pipercub66
Registered User
Canada, AB, Cold Lake
Joined Oct 2012
13 Posts
Discussion
EME AutoStart Installation

I have just installed an EME AutoStart unit on my DLE 55. The mechanical part went very well. However, I would like some advice from anyone who has installed one of these. In particular, I need to know how to wire the controller in. My controller has two xt90 terminals, one on each side of a black box. On one side, near the terminal is a red light. Which goes there, the battery input , or the output to the starter motor. Also, what strength of battery should I use. My thanks for any and all help offered, fellows.
pipercub66 is offline Find More Posts by pipercub66
Reply With Quote Quick reply to this message
Sign up now
to remove ads between posts
Old 04-15-2020, 04:30 AM
ptman is offline
Find More Posts by ptman
Registered User
United States, FL, Bradenton
Joined Aug 2006
86 Posts
I have one on my 55 with the old switch and working just fine, on my eme 70 I have the black switch that you are talking about and I believe that the side where the light goes to the starter motor the other to battery, I had to reverse mine because the starter is on the back of the motor, That what I was told from Mike at mile high rc and works just fine. Battery I am using a 2200 mil 3 cell that works just fine. Hope this helps.
ptman is offline Find More Posts by ptman
Reply With Quote Quick reply to this message


Quick Reply
Message:


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools