logo
Thread Tools
Old 01-30-2012, 12:23 PM
ericb is offline
Find More Posts by ericb
Team WTFO
ericb's Avatar
USA, SD, Worthing
Joined Mar 2006
9,613 Posts
Discussion
Hacker X20 esc problem

I am having problems with my X20 esc cutting power to the RX. Running the motor is fine, but when I use the servos, it cuts power to the esc for about a second. I have 2 witnesses that saw what it is doing. I tried another esc and it works just fine, so it is not the servos pulling to much juice. There is no binding in the servos either. Something wrong with the esc. Has anybody had this issue before?
ericb is offline Find More Posts by ericb
Reply With Quote Quick reply to this message
Sign up now
to remove ads between posts
Old 01-30-2012, 02:17 PM
ericb is offline
Find More Posts by ericb
Team WTFO
ericb's Avatar
USA, SD, Worthing
Joined Mar 2006
9,613 Posts
...
ericb is offline Find More Posts by ericb
Last edited by ericb; 01-31-2012 at 08:56 PM.
Reply With Quote Quick reply to this message
Old 01-31-2012, 08:56 PM
ericb is offline
Find More Posts by ericb
Team WTFO
ericb's Avatar
USA, SD, Worthing
Joined Mar 2006
9,613 Posts
Anybody?
ericb is offline Find More Posts by ericb
Reply With Quote Quick reply to this message
Old 01-31-2012, 09:14 PM
STLAV8R is online now
Find More Posts by STLAV8R
Team Twisted!
STLAV8R's Avatar
United States, MO, St Louis
Joined Mar 2006
5,669 Posts
I have been flying several Hacker X-20 Pros for over 6 years now. Have hundreds of flights. Never had an issue with any of them.

You might want to try posting on RC Groups...
STLAV8R is online now Find More Posts by STLAV8R
Reply With Quote Quick reply to this message
Old 01-31-2012, 10:34 PM
ericb is offline
Find More Posts by ericb
Team WTFO
ericb's Avatar
USA, SD, Worthing
Joined Mar 2006
9,613 Posts
Quote:
Originally Posted by STLAV8R View Post
I have been flying several Hacker X-20 Pros for over 6 years now. Have hundreds of flights. Never had an issue with any of them.

You might want to try posting on RC Groups...
Thanks, I will do that. Where would a person send it in the USA to get worked on?
ericb is offline Find More Posts by ericb
Reply With Quote Quick reply to this message
Old 02-01-2012, 12:30 PM
wfield0455 is online now
Find More Posts by wfield0455
Registered User
wfield0455's Avatar
United States, MA, Holliston
Joined Oct 2007
2,866 Posts
Quote:
Originally Posted by ericb View Post
I am having problems with my X20 esc cutting power to the RX. Running the motor is fine, but when I use the servos, it cuts power to the esc for about a second. I have 2 witnesses that saw what it is doing. I tried another esc and it works just fine, so it is not the servos pulling to much juice. There is no binding in the servos either. Something wrong with the esc. Has anybody had this issue before?
Is this with a fully charged battery or one that's mostly discharged. I've seen a similar sounding problem with a different ESC when using the Turnigy Nano-Tech packs. The problem I saw was instead of doing a soft shutdown when the pack got low, it killed the BEC and shut down the receiver/servos but left the motor running. Is that what you saw?
wfield0455 is online now Find More Posts by wfield0455
Reply With Quote Quick reply to this message
Old 02-01-2012, 12:32 PM
ericb is offline
Find More Posts by ericb
Team WTFO
ericb's Avatar
USA, SD, Worthing
Joined Mar 2006
9,613 Posts
Quote:
Originally Posted by wfield0455 View Post
Is this with a fully charged battery or one that's mostly discharged. I've seen a similar sounding problem with a different ESC when using the Turnigy Nano-Tech packs. The problem I saw was instead of doing a soft shutdown when the pack got low, it killed the BEC and shut down the receiver/servos but left the motor running. Is that what you saw?
Fully charged. I tried it with 3 different packs also.
ericb is offline Find More Posts by ericb
Reply With Quote Quick reply to this message
Old 02-01-2012, 12:35 PM
exeter_acres is offline
Find More Posts by exeter_acres
tap....tap.tap... is this on?
exeter_acres's Avatar
Johns Creek, GA
Joined Jan 2006
8,629 Posts
what did the folks at Hacker say when you contacted them first?
http://www.aero-model.com/
exeter_acres is offline Find More Posts by exeter_acres
Reply With Quote Quick reply to this message
Old 02-01-2012, 12:46 PM
ericb is offline
Find More Posts by ericb
Team WTFO
ericb's Avatar
USA, SD, Worthing
Joined Mar 2006
9,613 Posts
Quote:
Originally Posted by exeter_acres View Post
what did the folks at Hacker say when you contacted them first?
http://www.aero-model.com/
I have not contacted them yet. I really didn't know who to contact. I was not sure if aero-model was the correct place to start. I will contact them today.

Thanks
ericb is offline Find More Posts by ericb
Reply With Quote Quick reply to this message


Quick Reply
Message:


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools