logo
Thread Tools
Old 08-03-2017, 07:53 AM
74Ranch is offline
Find More Posts by 74Ranch
Registered User
74Ranch's Avatar
United States, VA, Midlothian
Joined Sep 2013
434 Posts
I got the EME 35 with electric start. nice engine and I just ordered the EME60 with electric start to put in my Bill Himpel XD Decathlon. plenty of room for the electric start and the weight is not bad at all.
74Ranch is offline Find More Posts by 74Ranch
Reply With Quote Quick reply to this message
Sign up now
to remove ads between posts
Old 08-03-2017, 11:03 AM
raydar is offline
Find More Posts by raydar
Registered User
Joined Nov 2009
1,179 Posts
Cheers for the pictures Stingray, at least I know my options now.

She is looking good you enjoy flying her? and how did the stockn landing gear last for you.
raydar is offline Find More Posts by raydar
Reply With Quote Quick reply to this message
Old 08-03-2017, 08:51 PM
stingray528i is offline
Find More Posts by stingray528i
Registered User
United States, NC, Wilmington
Joined Nov 2010
811 Posts
Quote:
Originally Posted by raydar View Post
Cheers for the pictures Stingray, at least I know my options now.

She is looking good you enjoy flying her? and how did the stockn landing gear last for you.
I really like my stang, flys great and get compliments on her every time I take her out. Still running stock retracts but they can be a bit fiddly at first. Are you thinking about getting one of these birds ? If you are or have more questions just give a shout out but maybe we should take them to the Phoenix P51 thread and not stomp on this thread too bad
stingray528i is offline Find More Posts by stingray528i
Reply With Quote Quick reply to this message
Old 08-04-2018, 06:07 PM
atchfoot is online now
Find More Posts by atchfoot
Registered User
United States, KS, Atchison
Joined Feb 2008
198 Posts
EME 60 carb issue

I have a well broken in EME 60 with Walbro carb that has about 6-7 gallons through it that has been running well with a Falcon 24x9 with standard exhaust at ~6500rpm. The other day I tried turning the high speed needle in to lean out the top end, and found it had no effect on the engine running at all. In fact I closed the needle completely and it ran unchanged. I started over and turned both screws out to factory recommended start point, and adjusted the low end until it just transitions nicely from idle during throttle up, but the high speed needle still has no effect.


Took carb off, reeds are sealing and look fine, screen was cleaned, carb disassembled and flushed with carb cleaner, gaskets fitting well with no apparent leaks. Reassembled and it still runs exactly the same. Still gets ~6500 static, idles well and transitions smoothly. However, turning the high speed needle still has abolutely no effect on how the engine runs.


Has anyone run into this and is there a remedy? New carb?
atchfoot is online now Find More Posts by atchfoot
Reply With Quote Quick reply to this message
Old 08-05-2018, 11:01 AM
Texastbird is online now
Find More Posts by Texastbird
Registered User
Texastbird's Avatar
United States, TX, La Porte
Joined Oct 2008
1,258 Posts
I would try another carb if the tank plumbing is good.
Texastbird is online now Find More Posts by Texastbird
Reply With Quote Quick reply to this message
Old 08-05-2018, 06:47 PM
atchfoot is online now
Find More Posts by atchfoot
Registered User
United States, KS, Atchison
Joined Feb 2008
198 Posts
I agree. Got a new one on order from Mile High.
atchfoot is online now Find More Posts by atchfoot
Reply With Quote Quick reply to this message
Old 08-09-2018, 05:20 PM
atchfoot is online now
Find More Posts by atchfoot
Registered User
United States, KS, Atchison
Joined Feb 2008
198 Posts
New Walbro from Mile High fixed it!! The high speed needle can be screwed in until you notice the rpm drop a little, then richened up. Old carb would not produce a lean mixture even when high speed needle was closed.
atchfoot is online now Find More Posts by atchfoot
Reply With Quote Quick reply to this message
Old 09-05-2018, 05:47 AM
Lifer is offline
Find More Posts by Lifer
Lifer
Kansas City, Missouri
Joined Jun 2010
222 Posts
I sent Mike a note on the 60cc carb issue. My engine's high-speed needle has no affect at all. He didn't respond to that specific issue so I requested clarification.



Atchfoot: Which carb from his website did you select? Also, did you need to modify your linkages as a result of the carb change?


Thanks in advance.
Lifer is offline Find More Posts by Lifer
Reply With Quote Quick reply to this message
Old 09-05-2018, 07:26 AM
atchfoot is online now
Find More Posts by atchfoot
Registered User
United States, KS, Atchison
Joined Feb 2008
198 Posts
I replaced the stock carb with another new stock carb from the Mile High website. Linkages were the same . The new carb could be leaned out until the engine sagged a little when the high speed needle was closed which was better than the original. I didn't pick up any rpm though, it ended just a little better tune overall without sputtering as much at midrange.
atchfoot is online now Find More Posts by atchfoot
Reply With Quote Quick reply to this message
Old 09-06-2018, 04:28 PM
antique is offline
Find More Posts by antique
older than dirt,
antique's Avatar
United States, AZ, Williams
Joined Aug 2007
2,074 Posts
A Walbro will work with the high needle closed if the low needle is opened too far...The OLD G38s all did that...
antique is offline Find More Posts by antique
Reply With Quote Quick reply to this message


Quick Reply
Message:


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools