logo
Thread Tools
Old 03-03-2015, 08:28 PM
flybaby505 is offline
Find More Posts by flybaby505
AmericanSpectre
flybaby505's Avatar
United States, NC, Fayetteville
Joined Jan 2006
747 Posts
Kool

Kool nappyroots, best of luck and happy flying!

Quote:
Originally Posted by nappyroots2182 View Post
well got the Talon 120HV firmware updated and got the plane outside and ran it up. very smooth. but i wasnt getting any pull untill about 3/4 power then it hit hard like a boost. came inside and started looking at the radio. i had endpoint at 59/105 so that might be it. but at least its smooth and im on the right track. at pull power it is stronger then the 40cc i took off. cant wait to finish it up.
flybaby505 is offline Find More Posts by flybaby505
Reply With Quote Quick reply to this message
Sign up now
to remove ads between posts
Old 03-03-2015, 08:30 PM
flybaby505 is offline
Find More Posts by flybaby505
AmericanSpectre
flybaby505's Avatar
United States, NC, Fayetteville
Joined Jan 2006
747 Posts
Mezon

The Mezon is awesome, you can actually program it for 28 pole motor, if I remember correctly.

Quote:
Originally Posted by MaceH View Post
Yup, Edge was a no go with my Torque Silver Bullet, a Q60 clone, I think. And the Edge was not returnable once connectors had been attached though it will work fine in my choppers. IF my Mezon fails I'll try the Edge with the new firmware....
flybaby505 is offline Find More Posts by flybaby505
Reply With Quote Quick reply to this message
Old 03-04-2015, 05:44 PM
nappyroots2182 is offline
Find More Posts by nappyroots2182
Registered User
nappyroots2182's Avatar
United States, IL, Moline
Joined Oct 2008
1,897 Posts
few more tests today. starts easy and smooth. crap tons of full power. not much pull under half throttle. trying to figure that out. maybe a throttle curve?
nappyroots2182 is offline Find More Posts by nappyroots2182
Reply With Quote Quick reply to this message
Old 03-10-2015, 07:18 PM
nappyroots2182 is offline
Find More Posts by nappyroots2182
Registered User
nappyroots2182's Avatar
United States, IL, Moline
Joined Oct 2008
1,897 Posts
flew this setup today. my motor was screeching so when i got home i tried some different timing settings and didnt help. went from the 8PWM Hacker tells me to use and tried outrunner mode. outrunner mode seems to cut the screeching down but would need to fly it again to find out. think i shouldnt have got this esc. never fails. hope to do some more tweeks and see if i can cure this
nappyroots2182 is offline Find More Posts by nappyroots2182
Reply With Quote Quick reply to this message
Old 03-11-2015, 06:02 AM
flybaby505 is offline
Find More Posts by flybaby505
AmericanSpectre
flybaby505's Avatar
United States, NC, Fayetteville
Joined Jan 2006
747 Posts
Brake

Are you using the brake and how much, if so turn it off and test it. That annoying sound can come from running to much brake. I ran mine in outrunner mode without any issues or 8kHz and 20* of timing on the 80 HV. I can send you a copy of the setup I used, I think. Make sure I still have a copy first...... The Talon 120 should not be any different.

Call Castle or email them. They will respond pretty quick.

Bill Holsten

Quote:
Originally Posted by nappyroots2182 View Post
flew this setup today. my motor was screeching so when i got home i tried some different timing settings and didnt help. went from the 8PWM Hacker tells me to use and tried outrunner mode. outrunner mode seems to cut the screeching down but would need to fly it again to find out. think i shouldnt have got this esc. never fails. hope to do some more tweeks and see if i can cure this
flybaby505 is offline Find More Posts by flybaby505
Reply With Quote Quick reply to this message
Old 03-11-2015, 10:45 AM
nappyroots2182 is offline
Find More Posts by nappyroots2182
Registered User
nappyroots2182's Avatar
United States, IL, Moline
Joined Oct 2008
1,897 Posts
no brake. sent Castle a email. waiting to here back. they are hit or miss on their emails. i dont see why the talon would run any different then other castles at the same settings. ive got to try a few more things quick before thinking of returning this esc. it ran good on the ground last nite once i played with outrunner mode. so ill try to get out tomorrow after work
nappyroots2182 is offline Find More Posts by nappyroots2182
Reply With Quote Quick reply to this message
Old 03-11-2015, 06:14 PM
flybaby505 is offline
Find More Posts by flybaby505
AmericanSpectre
flybaby505's Avatar
United States, NC, Fayetteville
Joined Jan 2006
747 Posts
Settings

I'm not sponsored by CC, but I did have good luck with my setup . I ran outrunner mode and it was just fine even with 40% brake (pattern plane). I was also, setup on 10s and I'm guessing you are running a 6S/12S configuration?

That is an A60-5XS?

Bill

Quote:
Originally Posted by nappyroots2182 View Post
no brake. sent Castle a email. waiting to here back. they are hit or miss on their emails. i dont see why the talon would run any different then other castles at the same settings. ive got to try a few more things quick before thinking of returning this esc. it ran good on the ground last nite once i played with outrunner mode. so ill try to get out tomorrow after work
flybaby505 is offline Find More Posts by flybaby505
Reply With Quote Quick reply to this message
Old 03-11-2015, 09:37 PM
nappyroots2182 is offline
Find More Posts by nappyroots2182
Registered User
nappyroots2182's Avatar
United States, IL, Moline
Joined Oct 2008
1,897 Posts
Hacker 60-5s. 8s. Hopefully I can fly it in outrunner mode tomorrow. It seems better on the getting in this mode vs. The 8kz mode
nappyroots2182 is offline Find More Posts by nappyroots2182
Reply With Quote Quick reply to this message
Old 03-12-2015, 06:22 AM
flybaby505 is offline
Find More Posts by flybaby505
AmericanSpectre
flybaby505's Avatar
United States, NC, Fayetteville
Joined Jan 2006
747 Posts
RE

I played with a bunch of settings in mine, including running an older firmware, which worked better than the newest one at that time (2012). The outrunner mode ran the best for me in the beginning. It ran even better when I got my endpoints adjusted and fine tuned. I tried changing timing and KHz , the motor ran hotter in most cases. I went back to outrunner made, several other pattern guys were using the outrunner mode also.

Make sure you're motor and esc is staying cool enough, if you have an IR temp gauge, check it and then check the software recordings for temp. A really hot motor will Squeal too...

Bill


Quote:
Originally Posted by nappyroots2182 View Post
Hacker 60-5s. 8s. Hopefully I can fly it in outrunner mode tomorrow. It seems better on the getting in this mode vs. The 8kz mode
flybaby505 is offline Find More Posts by flybaby505
Reply With Quote Quick reply to this message
Old 03-12-2015, 10:42 AM
nappyroots2182 is offline
Find More Posts by nappyroots2182
Registered User
nappyroots2182's Avatar
United States, IL, Moline
Joined Oct 2008
1,897 Posts
it will squeal even as soon as its fired up before heat gets to it. yes i will keep an eye on temps as it gets hotter outside.
nappyroots2182 is offline Find More Posts by nappyroots2182
Reply With Quote Quick reply to this message
Old 03-14-2015, 07:26 AM
flybaby505 is offline
Find More Posts by flybaby505
AmericanSpectre
flybaby505's Avatar
United States, NC, Fayetteville
Joined Jan 2006
747 Posts
RE

When you turn the motor by hand can you feel any points that drag or click?


Quote:
Originally Posted by nappyroots2182 View Post
it will squeal even as soon as its fired up before heat gets to it. yes i will keep an eye on temps as it gets hotter outside.
flybaby505 is offline Find More Posts by flybaby505
Reply With Quote Quick reply to this message
Old 03-15-2015, 08:04 AM
nappyroots2182 is offline
Find More Posts by nappyroots2182
Registered User
nappyroots2182's Avatar
United States, IL, Moline
Joined Oct 2008
1,897 Posts
I talked to castle. They have me set to sty end points and 0 timing. It's much better and don't squeal the whole flight. Just mainly when I'm hanging on the prop.
nappyroots2182 is offline Find More Posts by nappyroots2182
Reply With Quote Quick reply to this message
Old 03-15-2015, 10:34 AM
flybaby505 is offline
Find More Posts by flybaby505
AmericanSpectre
flybaby505's Avatar
United States, NC, Fayetteville
Joined Jan 2006
747 Posts
RE

LOL..., okay.

Good news,..zero timing, that's interesting.


Quote:
Originally Posted by nappyroots2182 View Post
I talked to castle. They have me set to sty end points and 0 timing. It's much better and don't squeal the whole flight. Just mainly when I'm hanging on the prop.
flybaby505 is offline Find More Posts by flybaby505
Reply With Quote Quick reply to this message
Old 03-15-2015, 01:19 PM
nappyroots2182 is offline
Find More Posts by nappyroots2182
Registered User
nappyroots2182's Avatar
United States, IL, Moline
Joined Oct 2008
1,897 Posts
This is an odd problem as all or our ESCS have the same reverse expo throttle curve that makes throttle response linear with all electric motors. All electric motors actually show very little throttle response until the last 80% of power hence the reverse exponential curve. The only way throttle response could low at low throttle settings is either there is strange throttle output from the transmitter or something else external to the ESC.

As far as ESC settings go, change throttle type for ‘Airplane’ vehicle type to ‘Fixed Endpoint.’ Then follow the transmitter calibration process outlined in a video on our website. (Second vid from top http://www.castlecreations.com/suppo...al_videos.html.) In the ‘Motor’ tab change ‘Motor Timing’ to Low (0) which will actually produce the high timing these motors want without tripping over the 30 degree timing maximum which will cause the motor to lose power and run poorly at high throttle settings. This is because our timing is dynamic meaning advance changes with the speed and load on the motor to allow any motor to run at its maximum efficiency at any speed. In addition our ESCS adapt themselves to the motor they are running and with high inductance motors, like all large out runners, sets the dynamic timing range higher than normal as this is what these motors want. The only problem is with larger out runners there is so much inductance it can pull timing too high.
nappyroots2182 is offline Find More Posts by nappyroots2182
Reply With Quote Quick reply to this message
Old 03-15-2015, 01:19 PM
nappyroots2182 is offline
Find More Posts by nappyroots2182
Registered User
nappyroots2182's Avatar
United States, IL, Moline
Joined Oct 2008
1,897 Posts
That is what they emailed me
nappyroots2182 is offline Find More Posts by nappyroots2182
Reply With Quote Quick reply to this message


Quick Reply
Message:


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools